Kyno is now owned by Signiant, Inc. Signiant’s EULA for Kyno will apply to new licenses as well as to Kyno support services and updates that we may provide. In addition, Signiant’s global privacy policy will apply in each case where Signiant’s EULA for Kyno applies, as well as to any communications with us about Kyno. Read the full announcement.
Start a new topic

Screen display problems with Kyno 1.8


I just downloaded Kyno 1.8 Trial to see how well it will work for my workflow with Resolve 16.2.x.

I have a newly built PC with the following specs:

AMD R9-3950x

Gigabyte Aorus GTX 1080Ti (running the latest NVIDIA drivers (442.92))


ASUS Crosshair VIII

2TB M.2 NVME Gen 4 SSD (Boot)

2TB (RAID 0, 4x500GB SSD) (video editing)

Dual Dell u2413 1920x1200 SDR monitors (calibrated)

I am testing the software on one of my daughter's soccer games. 

The first time I tried skimming through the first of 4 total videos it played back OK.  However, when I tried to actually create a sub-clip with in/out points and add metadata, the "screen" redraws began to get messed up. The Metadata, Content, Subclips, Tracks tabs "duplicated/overlapped" themselves.  In addition, the entire area below the video playback (excepting the time code, which was also duplicated/overlapped) turned into a solid, if irregular, white block (over the area where the File, Size, Modified, Created, etc. information is displayed).

I closed the application and tried again.  I was able to get most of the way through setting the in/out points and added the metadata, but by the time I finished with the first sub-clip and metadata, the area under the Devices (the area where drive/folder tree is displayed) had duplicated itself over the area that was white the previous time.

I do not have any similar problems with any other applications I use, including browser, Resolve, a couple games, etc., apps that I would expect to demonstrate problems if this were hardware (e.g. memory, video cards, etc.).  I currently have about 16GB RAM in use and about 46GB free.  Kyno is using just under 2GB of RAM.

I have been a formal beta tester for a number of applications in the past and this feels like that.  Is 1.8 not a full release?

I have attached an example of the screen redraw problem.  In this case, I was able to create sub-clips through about 26 min of video (the end of the first clip) and when I clicked on the "4 squares" icon to view all of the associated media in this sub-directory, you can see what happened.

The only way I know of to "fix" the problem is to close Kyno and restart it.

Is anyone else having similar problems?


1 person has this problem

Thank you for sharing! I have confirmation from another user that uninstalling Sonic Studio helped with the render problems. We have a private beta version of Kyno with tooltips disabled as those were a candidate for causing the issues. If anyone would like to try it out just reply here and I'll send you the link.

1 person likes this

Scott, I've solved the issue and think i know how. let me know if you want the fix to try so you can properly evaluate the software before purchasing it.

now that i have it working i may purchase, but also evaluating  a great deal CATDV was offering me for a full version.

1 person likes this

THIS IS happening on one my machine, it's running fine on a one machine as trial with nvidia 2060 running prerelease.200904-11619 w10 on 24coreintel

it is NOT working and exhibiting exactly what you describe.on nvidia 1650 i3 same os version (the current dev channel insider build)

I though memory leak, but it does it right from the install w/o any media in workspace.

It gets corupted when using any of the dropdowns like CONVERT OR THE FILTER DROP and all dropdowns in the file bar and everywhere else. 

It can only be used if you dont touch any of those and keyboard all over. but still all the export windows like send to resolve that has dropdowns and radio buttons.

so whatever is being used for the interface framework is not compatible or stable.  i dont know what this program is build in for the UI.

both machines have similar or same nvidia global 3d settings-  performance prefered rest is vanila settings.

being that it works on one machine and not the other is dealbreaking for purchase.

without response and resolution from devs, yall stop the multiple uninstall/installs or messing with your video drivers.  the app is incompatible.

hope it gets fixed- it's not a CATDV but it is way easier to tag a ton of footage and then shove it to resove and use smartbins (tags) makes it pretty good. but....



1 person likes this

goto   install CatDV Pro 13.0.12.exe  see if it works, its a demo and legit software so not a scam.  i do not recall rebooting nor opening catdv after install.

eager to hear if it does anything for you, it did on my machine.

after working with kyno, its helpful as another offload tool and tagger, but for me it looks like i need a full library mam like catdv.  I'll probably just upgrade my key for that.

if this can work correctly i could see using it but not for this price nor support response.  it seems to sit in the middle of offloader and MAM library.  for me i need a library that i can sling a bunch of clips into a bin or seq to send off to edit.  this is halfway there.


1 person likes this

@LAMAR I did so and unfortunately it didn't fix the issue for me. Wish an official fix from the now-ironically-named Lesspain Software could come after months of this persistent issue breaking our workflow. Been a paying customer of Kyno since it came out and have purchased multiple seats - it's disappointing to say the least to be left high-and-dry now. The second a comparable competitor is available with stronger support, I'm done.

1 person likes this

I'm having this exact same problem on Window with Kyno


1 person likes this
Sadly, the only responses to this thread are by people who are also having this problem. The devs seem to be unwilling to acknowledge, much less fix the problem. It is very frustrating to me as I can see a lot of potential, but, as is, it is unusable to me... Scott

1 person likes this

@Thomas I'd love to. I can't use Kyno at all right now, so I'm up for anything. 

@LAMAR - please share! Kyno is a critical part of our workflow and it's been a nightmare working around this issue.

No one has any thoughts?  Kyno tech support?  Kyno forum personnel?

For all practical purposes, it is unusable.  At least as a "professional" tool.  One of the reasons I left Adobe Premiere was because of the (less frequent) crashes.  Ok, Kyno hasn't "crashed", but the screen redraw issue makes it equally unable to use.


We've had another report regarding the redraw issues on Windows and the user was able to isolate a software called "Riva Tuner Statistics Server" that comes bundled with "MSI Afterburner" as the cause. If any of you experiencing this issue have the software installed it'd be great to know. Possible that there are different causes for the problem but it may be worth checking.

I've checked and do not have MSI Afterburner installed on my system. I do have Ryzen Master and Aorus Engine software installed. I just uninstalled them both. After rebooting, it does seem to make some difference. However, instead of the problems appearing immediately, I am able to create 3-4 subclips before the screen redrawing problem arises. Both Afterburner and the Aorus Engine are both tweaking software for Nvidia graphics cards... that are supplied by the card manufacturers and are included in the box (at least it was with my 1080ti). Perhaps that is a common thread between the two. That said, I'm still having the screen redraw problem, even after uninstalling the above software. I can't use the software, as is. (Note: I am using v1.8.1 of the software.) Anyway, while that did appear to help a bit, it did not resolve the problem. I stand by my recommendation to change from a Java based UI to one based on another language, like C/C++. I'm going to try uninstalling all versions of Java and do the install Ashwin to see if that makes a difference. I don't use much anymore and will see if a fresh install helps. Scott

I've checked and I do not have either of those installed on mine. 

Lamar, Yes, please do let us know what you have done to fix this problem! Kyno is the closest thing I've found to Adobe Prelude, especially that works with Resolve, and if really like to give it a fair shake if I can fix these display problems! Scott
Login or Signup to post a comment